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C H A P T E R  1 8

Digital Audio

Today’s PC is a multimedia powerhouse, and it’s hard to come across a home computer 

that doesn’t have at least a set of speakers attached. Some people take this to extremes 

and have surround-sound speakers on their computers, as well as large monitors for 

crystal-clear video playback. 

The people behind Ubuntu aren’t blind to this, and include not only audio playback 

software but also a video player with the distribution. In this chapter, you’ll learn how to 

listen to MP3s, CDs, and Internet radio on your Ubuntu system. You’ll also learn how to 

configure Skype, the most popular Internet telephony application. In the next chapter, 

you’ll learn how to manage video playback.

Issues Surrounding Multimedia Playback
As you might have read in the press, multimedia playback on computer devices, and 

Linux in particular, is hindered by a number of issues. The main ones are software patents 

and Digital Rights Management (DRM).

Audio and video playback technologies such as MP3 and MPEG are patented in coun-

tries that allow software to be patented, such as the United States. A patent protects the 

implementation of an idea, as opposed to copyright, which protects the actual software. 

Patents are designed to restrict distribution of the technology utilizing a particular idea, 

unless permission is granted, usually via a payment to the license holder.

Because Linux is based on the sharing of computing technology and knowledge, organiza-

tions like Ubuntu are fundamentally and philosophically opposed to any kind of software 

patenting. As such, they try to avoid distributing such software, which is why MP3 play-

back is not supported natively within Ubuntu, for example. This doesn’t make playback of 

popular music and video files impossible, but it means that extra software must be down-

loaded and installed (although the process is automated). Additionally, the use of patented 

software raises ethical issues, such as the fact that using patented software runs counter 

to the aims of Linux and the open source movement. 
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■Note  It isn’t the job of this book to dictate a position for you on the ethics of using software that has been 

patented. That’s something you must do on your own. It’s a very complicated issue, but Wikipedia has a good 

summary of the arguments: http://en.wikipedia.org/wiki/Software_patent. 

Much more devastating than patenting is DRM, a technology tied into audio or video 

playback software. It’s designed to control how, where, when, and on what device you can 

play certain media. For example, Apple’s iTunes DRM scheme means you can play back 

movies and some audio tracks bought from iTunes only on the iPod range of devices 

(including the Apple TV and iPhone range of devices) or using the iTunes software. DVD 

and Blu-ray movie players include forms of DRM called Content Scrambling System (CSS) 

and Advanced Access Content System (AACS), respectively, which prevent users from 

playing DVDs on computers unless special software is purchased. The situation for audio 

tracks is getting better, and many large music companies are slowly abandoning DRM on 

audio tracks they sell, but nearly all movie files remain affected. 

Perhaps it goes without saying that the Linux community, including the Ubuntu project, is 

fundamentally opposed to any kind of DRM. Because of this, practically no DRM software 

has been officially ported to Linux, so you can’t, for example, play music purchased via 

the Napster online store or movies purchased from the iTunes online store.

Linux and other open-source projects are very resourceful and are often able to reverse-

engineer technology formats in order to get around DRM or patent issues. But the laws in 

many countries—with the United States as a particularly strident example—prohibit 

reverse-engineering in this way. In addition, the laws in some countries seek to prohibit 

use of software resulting from this process. 

■Note  You may be wondering why music and movie corporations are so intent on enforcing DRM and 

patenting if these schemes give their customers such a hard time. To learn more, and to find out what you 

can do to help halt the progress of such technology, visit the Electronic Frontier Foundation’s web site: 

www.eff.org. 

Programmers have also come up with Free Software alternatives to proprietary formats. 

Examples include the Ogg media format, which is every bit as good as MP3 but is unen-

cumbered by patent issues. We’ll look at using Ogg later in this chapter, in the “Choosing 

a Format” section; it’s an excellent way of avoiding issues surrounding patenting. However, at 

the moment, there’s no ideal open-source video format, or at least not one that’s in wide-

spread use.

As an end user migrating to Ubuntu from Windows or Mac OS X, it’s likely you’ll want 

to add support for MP3 and popular video file playback formats, at least until you can 
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switch over to open-source file formats. Throughout this and the next chapter, we’ll 

examine installing media playback software and using it in concert with Ubuntu’s built-in 

playback software, even though some of that software may have issues surrounding 

patenting. In one case, the software is designed to bypass the DRM scheme that protects 

DVD movie discs.

■Note  The United States and Japan both have laws allowing software to be patented. Most other countries, 

including those within the European Union, do not currently allow software patents. 

Playing Audio Files
Audio playback under Ubuntu is normally handled by the Rhythmbox player. This is a 

feature-packed piece of software that can play back audio files, podcasts, Internet radio, 

and even CDs. However, Totem, the Ubuntu movie player, can also play back digital 

audio files. Additionally, Sound Juicer can play audio CDs. 

Like many modern music players, Rhythmbox can also manage your music collection, 

arranging it into a library so you can locate songs easily and create playlists. This makes it 

a better choice for playback if you have many digital audio files, although Totem is good 

for quick playback of individual files, such as auditioning those you’ve just downloaded. 

Out of the box, Ubuntu supports playback of Ogg Vorbis and FLAC across all its audio 

playback applications. These are two open-source audio file formats, which you’ll learn 

more about in the “Choosing a Format” section later in this chapter. 

To play back other music file formats, such as the ubiquitous MP3 format, additional 

software known as codecs must be installed. A codec handles the decoding (and also 

encoding) of multimedia files, both audio and video. The word is a shortened version of 

coder-decoder. For any digital multimedia file type you want to play on your computer, 

you’ll need an appropriate codec. In addition, if you wish to create your own multimedia 

files—for example, to create MP3s from CD audio tracks—you might need to download an 

additional codec that allows the encoding of files. 

Installation of codec software is largely automated. However, the issue of patenting 

continues to have an impact on the distribution of codecs. What’s more, the issue has not 

been resolved with 100% clarity, leaving many end users in a legal gray area. Several audio 

codecs available for Linux, contained in various gstreamer-plugins software packages, 

are not licensed with the patent holders. This is of little issue to you, as an end user. It’s a 

practical concern only for the distributors of the codecs, because the laws of some coun-

tries state that it’s their duty to pay patent licensing fees. But it’s something you should be 

aware of.
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MULTIMEDIA PLAYBACK COMPONENTS

In simple terms, three software components are needed for multimedia playback under Ubuntu: 

• Player application: This is the software that’s actually used to listen to music or display videos. 

It’s the part of the multimedia system that you interact with. Under Ubuntu, Totem Movie Player is 

used to play back video, and Rhythmbox is used to handle audio. However, if you install the KDE 

desktop, Kaffeine will be used to play back movies, and armaroK will be used to handle audio playback. 

• Multimedia framework: This is the behind-the-scenes middleman that puts the player applica-

tion in touch with the codec plug-ins. The multimedia framework preferred by Ubuntu is called 

GStreamer; the multimedia framework preferred by KDE is called Xine. The multimedia framework 

is a background component of your system, and you won’t come into direct contact with it, apart 

from when you’re initially configuring your system for media playback. However, it’s important 

to note that more than one multimedia framework can be installed, because this is sometimes 

necessary to utilize certain codecs. In Chapter 19, you will learn how to install an additional frame-

work in order to fully support DVD playback under Ubuntu. 

• Codec plug-ins: Codecs are the small pieces of software that handle multimedia file decoding. 

Codecs do all the hard work—the number-crunching. Most multimedia file formats are compressed, 

to make for smaller file sizes, and the codec’s job is to expand the files again, so that they can be 

played back on your computer. Some codecs also work the other way around by shrinking files; if 

you rip CD tracks to MP3, or convert DVD videos to movie files on your hard disk, you will need to 

shrink them for ease of storage.

Under Ubuntu, the GStreamer multimedia framework is installed by default, along with a handful 

of codecs. 

Installing Codecs

The codec software necessary for multimedia file playback and encoding can be found in 

Ubuntu’s online software repositories. However, there’s no need to use the Synaptic Package 

Manager program to install them manually. Multimedia applications automatically suggest 

which codecs to download and install when they attempt to play multimedia files. 

What actually happens is that plug-ins for the GStreamer multimedia framework are 

installed. These plug-ins contain the codec software. The multimedia framework is the 

behind-the-scenes software that underpins all of Ubuntu’s audio and video playback, 

including the Rhythmbox audio player and Totem Movie Player. As a user, you won’t 

come into direct contact with GStreamer, except when initially installing codecs. The 

benefit is that all of Ubuntu’s audio and video software uses it, so you need to install plug-

ins only once for the entire system. 
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Here, we will walk through installing the codec required for MP3 playback. The same 

procedure will apply when you try to play back any unsupported audio or video file 

format; all that will differ is the choice of codecs offered to you:

1. Copy an MP3 file to your desktop.

2. Double-click the MP3 file.

3. Totem Movie Player will start up, but because the underlying GStreamer framework 

doesn’t yet include support for MP3 files, a dialog box will appear, asking if you 

want to look for a suitable codec to play the file. Click the Search button to do so. 

The process is automated, but your computer will need to go online, if it isn’t already.

■Note  You might be told your list of software packages is out-of-date. If this is the case, click the Reload 

button in the dialog box that appears. This will refresh the repository list; it’s the equivalent of clicking the 

Reload button in the Synaptic Package Manager. 

4. The Install Multimedia Codecs dialog box will eventually appear, offering a choice 

of plug-ins to install. You’ll rarely be offered an individual codec to install. Most are 

bundled together with similar codecs allowing the playback of other file formats. 

As you can see in Figure 18-1, for playback of MP3 files, we were offered the GStreamer 

extra plugins bundle and the GStreamer ffmpeg video plugin. In addition to allowing 

MP3 playback, these bundles will install software for playback of audio/video files 

encoded in MPEG1/2, WMV, ASF, and other formats. Although there are two choices, 

and therefore obviously some overlap in functionality, you should opt to install 

both by putting a check in the boxes alongside them. Ubuntu will handle any over-

lapping functionality automatically in the background. It’s always best to install as 

many codecs as possible when offered the chance. This will mean your computer 

will be suitably equipped for playback of virtually any file type. 

■Note  In case you’re wondering why a plug-in seemingly offering nothing but video playback would include 

support for MP3, the reason is that MP3 is actually one of the many audio components of the MPEG video file 

format. For more information, see http://en.wikipedia.org/wiki/MP3.

5. As soon as you put a check in each box, Ubuntu will ask you to confirm the choice, and 

will explain that use of the software might be restricted in certain countries, although 

with certain provisos. Read through the dialog box and either cancel or confirm your 

choice, depending on whether you think the rules explained apply to you.
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Figure 18-1. Ubuntu recommends codec packages to install so you can play your 

multimedia files.

6. Click the Install button. Because you are about to install software, you’ll need to 

enter your password when prompted. Note that, although you appeared to select 

two packages, you actually selected to install package bundles, containing many 

individual packages. On the progress bar, you will see that quite a few individual 

packages are being downloaded—about 14 on our test computer! 

7. The files will download and install automatically. Once the process has completed, 

a dialog box will tell you that everything has been successful, and ask if you want to 

install more software. Click the Close button. 

8. Playback of the file should start automatically in the player application. Every 

piece of playback software within Ubuntu will now automatically support MP3 

files, including Totem, Rhythmbox, and any other playback software you install 

that relies on the GStreamer framework (this will include any playback software 

designed for the GNOME desktop). 
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FLUENDO MP3 CODEC

As mentioned, some codecs available for Ubuntu have certain legal issues surrounding the patenting of 

software. However, you might be pleased to hear that one audio codec available for Ubuntu is licensed 

with the MP3 patent holder, and therefore washes cleaner than clean: the Fluendo MP3 codec. In an act 

of generosity, the Fluendo company paid the MP3 technology license and made its own decoder freely 

available for all Linux users. For more information, see www.fluendo.com/resources/

fluendo_mp3.php. 

The Fluendo codec doesn’t avoid the ethical considerations surrounding using patented technology, 

as discussed early in this chapter, but it does leave you in the best possible position. However, the 

Fluendo codec can be used only to decode MP3 audio. It can’t be used to encode MP3s, so if you wish 

to rip tracks to MP3 from audio CDs, you will have to use the less legally precise GStreamer plug-in 

packages (or, better still, encode your audio files using the open-source Ogg Vorbis format, which avoids 

patenting issues and doesn’t require installing any additional plug-ins!). 

We would advise you to install the Fluendo codec if you simply want to listen to your existing MP3 

tracks and would like to embrace open-source audio file formats from this point onward. To install the 

Fluendo codec, open the Synaptic Package Manager (System ➤ Administration ➤ Synaptic Package 

Manager) and click the Search button. Enter gstreamer fluendo mp3 in the text box. It’s likely only 

one result will be returned (in our tests, it was gstreamer0.10-fluendo-mp3), so click the check box 

alongside the entry, click Mark for Installation, and then click the Apply button on the toolbar. Once the 

software is installed, MP3 files should play in both Totem and Rhythmbox. 

Using Rhythmbox

Both Rhythmbox and Totem can be used for audio file playback under Ubuntu. Rhythmbox 

is best if you have a lot of tunes, because it is able to catalog and manage your collection. 

You’ll find it on the Applications ➤ Sound & Video menu. 

The first step when running Rhythmbox for the first time is to let it index your music 

files. To do so, click Music ➤ Import File or Music ➤ Import Folder. Then navigate to your 

music tracks on the hard disk. You can select more than one file or folder by Shift-clicking 

or Ctrl-clicking, just as in Windows. 

Note that, unlike iTunes or some other comparable programs, Rhythmbox doesn’t 

copy your music to its own library folders when cataloging your files. Instead, it merely 

creates an index of the files you already have. So before having Rhythmbox index your 

files, you should copy them to the Music folder within your /home directory. 

If you subsequently move or delete any files, Rhythmbox might get confused. This can 

be resolved by clicking Music ➤ Import Folder and rebuilding the index (for single files, 

click Music ➤ Import File). 
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■Tip  If disk space is a concern and your audio files are in the Windows partition, you could simply leave the 

files there, rather than copy them across. Rhythmbox will still be able to index them. You just need to navigate 

to your Windows partition under the /media directory when choosing to index files. The only caveat is if 

Windows wasn’t shut down cleanly, the Windows partition will not be mounted automatically under Ubuntu, 

so your music will not be available. To fix the situation, you should instead boot to Windows, do a file system 

check/repair, and then shut down cleanly. 

Rhythmbox starts in browse mode, which means that your music files are listed at the 

bottom of the program window. In roughly the middle-left of the program window, you’ll 

find a listing of the artists behind the MP3s in your collection. On the right, you’ll see the 

album that the music track is taken from (provided that information is included in the 

music file itself, such as the MP3 ID3 tags). Figure 18-2 shows an example of a Rhythmbox 

window.

Figure 18-2. Rhythmbox will organize your music tracks by artist or album. 
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Clicking the Browse button on the toolbar will exit browse mode and present a list of 

the tracks in your collection, which can be ordered by clicking the headings in the list. The 

default sort order is by artist.

Playing a track is simply a matter of double-clicking it in the list at the bottom. Once the 

track is finished, Rhythmbox will play the next track in the MP3 file list. At the top of the 

Rhythmbox window are transport controls that let you pause or play the track, skip tracks, 

repeat tracks, or switch to shuffle play (that is, random track selection). 

You can toggle displaying visual effects with the Visualization button. The display 

output is shown in the main window by default. The controls for customizing the effects 

are available at the bottom of the visual effects display and are made visible when you 

hover your mouse over the visual effects. You have the option to change the nature of the 

visualization effect; the quality of the effect; and whether the effect will be displayed 

within Rhythmbox, in a different window, or in full-screen mode. 

Beneath the transport controls is a slider that shows the progress through the current 

song and lets you cue forward and backward by clicking and dragging. 

To create a new playlist, click Music ➤ Playlist ➤ New Playlist (or press Ctrl+N). A text 

box will appear under the Playlists heading in the pane on the far left side of the program 

window. Type the new playlist’s name in the text box and press Enter. To add tracks to the 

playlist, click Music under the Library heading in the pane on the far left side of the program 

window, and then drag-and-drop files onto your new playlist entry. To start playing the 

tracks in the playlist, select it and double-click the first track in the list.

■Note  When you double-click an audio file in a Nautilus window, Ubuntu will start Totem Movie Player 

rather than Rhythmbox. This is good if you want to preview tracks, but to have them automatically imported 

into Rhythmbox when you double-click them, you’ll need to change the Open With preferences. This is easily 

done. Right-click any MP3 file in a Nautilus file browsing window, select Properties, and click the Open With 

tab. Ensure that the radio button alongside its entry in the list is selected, and then click the Close button. 

Purchasing from Online Music Stores
Rhythmbox allows you to purchase albums from the Magnatune (www.magnatune.com) and 

Jamendo (www.jamendo.com) online music stores. Jamendo works on the principle of 

Creative Commons (see http://creativecommons.org), so many tracks are free of charge, 

although you can donate money if you wish. 

Under the Stores heading on the leftmost pane of the Rhythmbox window, click 

Magnatune or Jamendo. You’ll see a brief introduction to the store while the catalog is 

downloaded. After the catalog is downloaded (indicated by the status bar at the bottom 

right of the program window), you will be able to browse through the available tracks, as 

if they were on your own computer. They will be sorted by artist and track name. Double-

clicking each track will download and play a high-quality preview.
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■Note  It might take a few moments for the catalog to download. In our tests, the Jamendo catalog took 

about 10 minutes to download.

You’ll also see that the main toolbar of Rhythmbox has changed. Several new icons 

appear, allowing you to purchase and download the album, buy a physical CD, or learn 

more about the artist. 

Purchasing from Magnatune

With Magnatune, you can listen to any of the songs in the album without paying for them. Any 

songs you do decide to purchase are free from copy protection (DRM), and artists earn 50% 

from your purchase. You can choose how much to pay for an album (the minimum is $5). 

■Tip  You can learn more about artists by viewing their Magnatune web pages. Click a relevant track and 

click the Artist Information button on the toolbar. This will automatically load the relevant page in Firefox.

To purchase an album, select a song in the music list that is included in the album you 

would like to purchase, and then click the Purchase Album button on the toolbar. The 

Purchase Magnatune Tracks dialog box will appear and prompt you for the amount you 

want to pay (from $5 to $18), as well as the audio format you prefer (Ogg, FLAC, WAV, vari-

able bitrate MP3, or 128k MP3), plus e-mail address and gift card or credit card 

information. Once you’ve finished filling in the information, click the Purchase button to 

buy and download the songs.

To purchase a CD, click the relevant button on the toolbar. Firefox will open, and you’ll 

be redirected to a page on the Magnatune web site where you can fill in your credit card 

and address details. 

Using the Jamendo Store

Songs from Jamendo are free to listen to, download, and share, due to its flexible license 

based on Creative Commons. If you opt to purchase tracks of albums, 50% of the proceeds 

go to the artist. 

■Tip  Not only can you download the tracks from Jamendo, but you can also remix them or use snippets of 

them in your own music. All of this is because of the use of the Creative Commons license. 
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If you want to download an album, select a song in the music list that is included in the 

album you would like to download, and then click the Download Album button on the 

toolbar. Firefox will visit a URL that includes a BitTorrent tracker file—effectively, a small 

file that opens the Transmission BitTorrent client built into Ubuntu. BitTorrent will then 

attempt to download the entire album. 

■Note  BitTorrent is a unique file-sharing system designed to share bandwidth. Depending on your hard-

ware setup, you might need to alter your router or firewall settings for it to work. For more information, see 

www.dessent.net/btfaq/. 

If you want to make a donation to an artist, select a song in the music list that the artist 

performed and click the Donate to Artist button on the toolbar. Firefox will direct you to a 

web site where you can fill in a form to complete your donation.

Tuning In to Online Radio Stations
With Rhythmbox, you can listen to a number of predefined Internet radio stations or add 

your own. Provided the MP3 codec software is installed, as discussed previously, Rhythmbox 

is compatible with streaming MP3-based playlists, such as those listed at http://

shoutcast.com.

To view the available stations, click the Radio heading in the list on the left side of the 

Rhythmbox window. To listen to a radio station with Rhythmbox, double-click its entry in 

the list. To stop playback, deselect the Play button on the toolbar by clicking it. 

To add a new station, you can do either of the following:

• Right-click in a blank area below the list of existing stations on the right side of the 

program window and click New Internet Radio Station. Then enter its URL. Radio 

stations usually show the URL for their audio streams on their web sites.

• Open the radio station’s playlist (.pls) within Rhythmbox by downloading it directly 

from a web site. For example, browsing to the Shoutcast web site and clicking the 

Tune In button alongside a station listed there will open a dialog box that lets you 

download or open the .pls file. 

Opening the .pls file is the easier way of adding a radio station, but unfortunately, the 

default player in Ubuntu for .pls files is Totem, which can cause some confusion. However, 

the situation can be remedied easily. To open the .pls file with Rhythmbox instead, follow 

these steps:
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1. Under the Open With drop-down list that appears when you attempt to download 

a .pls file, select Other, and then click OK. 

2. The Choose Helper Application dialog box appears. Press Ctrl+L, and then type the 

following in the Location box: /usr/bin/rhythmbox. 

3. Click Open. 

4. To make sure that Rhythmbox is the default helper application in Firefox for .pls 

files that you will download or open in the future in Firefox, in the file download 

dialog box, check Do This Automatically for Files Like This from Now On, and then 

click OK.

Once the station has been imported into the list of stations, you’ll then need to double- 

click its entry to tune in. Note that when Rhythmbox starts after you import a station, it 

won’t automatically switch to the radio station listing. You’ll need to select the Radio 

entry from the list on the left.

To delete a radio station from the list, simply right-click it and select Delete. 

■Tip  If you’re a fan of Live365 (www.live365.com), you should find that the .pls file downloads auto-

matically when you click the Play button alongside a radio station in the web site listing. The site will also open 

a playback browser window, which, if you have the correct audio codecs installed, will start playing the 

station. You can simply close this playback window. 

Listening to Podcasts
Podcasts are audio files that are distributed by RSS (Real Simple Syndication). This sounds 

complicated, but it’s actually quite simple. It means that, once you’re subscribed to a partic-

ular podcast, the audio files are downloaded automatically in the background, so that the 

latest episodes will always be available. This makes keeping up with the latest episodes 

effortless. Most podcasts take the form of MP3 files, but any audio file format can be used.

In terms of content, podcasts range from simple spoken blog entries, usually created 

by individuals, to podcasts that are more akin to radio shows and involve interviews. 

Some professional radio stations even release entire shows as podcasts, with the British 

Broadcasting Corporation (BBC) leading the charge (www.bbc.co.uk/radio/podcasts/

directory/). 
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Rhythmbox is able to handle podcast subscriptions under Ubuntu, and you can add a 

new subscription by clicking the Podcasts heading in the leftmost pane of Rhythmbox. 

Then right-click a blank spot in the track listing area, select New Podcast Feed, and enter 

the URL. However, a much easier way of adding a podcast is to use Firefox to browse to the 

link. Conveniently, Rhythmbox is fully compatible with the iTunes podcast format, which 

is perhaps the most prevalent podcast format at the present time. However, some addi-

tional work must be done to make Rhythmbox use the link: 

1. On the web page where the link is located, click the subscribe link for iTunes users. 

The nature of this link will vary from page to page. 

2. You’ll be invited to choose an application in which to play the podcast. Click the 

Choose button.

3. In the file browsing dialog box, press Ctrl+L and type /usr/bin/rhythmbox into the 

Location box (or simply navigate to the location). 

4. Click OK in the file dialog box, put a check in the box alongside Remember My 

Choice for itms Links, and then click OK in the Firefox dialog box. The podcast will 

then begin downloading in Rhythmbox. 

If you want to download a particular episode, right-click it and select Download Episode. 

■Tip  You can start listening to a podcast before it has completely downloaded. 

If only an RSS link is provided for the podcast (usually indicated on a web site by the orange 

RSS button), once you click it, Firefox will offer to subscribe to the link itself. You don’t want 

this to happen, so click the drop-down link alongside Subscribe to This Podcast Using, click 

Choose Application, and follow the previous instructions to browse to /usr/bin/rhythmbox, as 

shown in Figure 18-3. Put a check in the box alongside Always Use Rhythmbox to Subscribe to 

Podcasts, and then click Subscribe Now in the Firefox program window. 

■Note  Rather strangely, in our tests, some podcasts appeared under the Radio list in Rhythmbox. If the 

podcast appears to get lost when you’re importing it, be sure to check there first.
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Figure 18-3. The best way to subscribe to a podcast is to select it within Firefox and then 

choose to subscribe using Rhythmbox. 

Listening to Audio CDs
Playing back audio CDs is simple. Just insert the CD, and you should find that Rhythmbox 

starts automatically. Click the name of the CD in the leftmost pane (look under the Devices 

heading), and then click the Play button on the toolbar. 

If you prefer, you can listen to audio CDs using Sound Juicer instead. Simply close 

Rhythmbox, and then start Sound Juicer (Applications ➤ Sound & Video ➤ Audio CD 

Extractor). Figure 18-4 shows the same audio CD in Sound Juicer and Rhythmbox. 

In both Sound Juicer and Rhythmbox, provided you’re online, the track and artist 

information will be looked up online, so you should find a complete listing. To start 

playing the CD in either application, simply click the Play button. This is located at the 

bottom of the window in Sound Juicer and the top of the window in Rhythmbox. Both 

applications also offer a slider by which you can cue backward and forward in the track by 

clicking and dragging. 

To eject the disk, press the button on the front of the drive. If this doesn’t work, right-

click the Audio CD desktop icon and select Eject. 
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■Tip  As with all GNOME applications, hover the mouse cursor over each button to display a tooltip that 

describes what it does. 

If you find the track listing information is incorrect, as can sometimes happen with 

online lookups, you can correct it within Sound Juicer by slowly double-clicking the track 

name—click once and then, half a second later, click again (a little like renaming files 

within Windows/Mac). Then type the new name. To rename a track in Rhythmbox, right-

click the track and select Properties. Under Sound Juicer, you can then submit the revised 

track names to the online database by clicking Disc ➤ Submit Track Names. 

Figure 18-4. Sound Juicer and Rhythmbox offer simple but effective CD playback, and both 

look up artist and track information online.

Ripping Music from CDs
Converting audio tracks on a CD into digital music files you can store on your hard disk for 

personal use is informally known as ripping. It’s handled under Ubuntu using the Sound 

Juicer application (Applications ➤ Sound & Video ➤ Audio CD Extractor).
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■Note  Because of the way audio CDs work, you can’t simply insert the disc and then drag-and-drop the 

tracks onto your hard disk. They must be converted first. 

Before you start to rip CDs, however, you’ll need to decide the format in which you 

wish to store the audio files.

Choosing a Format

You have several basic choices for audio file formats, the main ones being Ogg Vorbis, 

FLAC, and MP3. Let’s look at what each has to offer.

Ogg Vorbis: This is the Free Software alternative to MP3. Unless you have a trained 

ear, you won’t be able to tell the difference between a Vorbis and MP3 file (if you do 

have a trained ear, then you may find Vorbis better!). The two technologies generate 

files of around the same size, an average of 4MB to 5MB per song. The advantage of 

Vorbis is that it’s completely open-source technology, so you there isn’t the ethical 

burden of using patented MP3 software and, therefore, working against the interests 

of the open-source software movement. The downside of Vorbis is that not many 

portable audio players support it (although this situation is slowly changing), and 

other operating systems like Windows won’t be able to play back Vorbis files unless 

some additional software is installed (see www.vorbis.com/setup). Therefore, Vorbis is 

perhaps best if you’re ripping files solely for use on your computer. 

FLAC: This stands for Free Lossless Audio Codec, and it’s the choice of the audiophile. 

Vorbis and MP3 are lossy formats, which means that some of the audio data is lost in 

order to significantly shrink the file. FLAC doesn’t lose any audio data but still manages 

to compress files to a certain degree (although they’re still much larger than an equiv-

alent MP3 or Ogg file). FLAC scores points because it’s open source, like Vorbis, but 

you’ll face the same lack of support in portable audio players and other operating 

systems (unless additional software is installed; see http://flac.sourceforge.net).

Speex: Originally designed purely for Voice over IP (VoIP), Speex was created for 

speech encoding. As such, it concentrates on audio frequencies generated during 

ordinary conversation. Aside from the fact that Speex is an open-source codec that 

claims to not employ any patented software methods, there really isn’t any reason to 

use it, even if you’re ripping speech tracks from a CD. It is built for transmission across 

low-bandwidth connections (or small file sizes). If hard disk capacity is an issue, then 

you might consider it, but Ogg and MP3 are better suited in virtually all situations. 

The Speex file extension is .spx. 
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WAV: This is perhaps the oldest audio file format. It uses the .wav file extension, which 

you may have seen in use on Microsoft Windows computers. WAV files are usually 

completely uncompressed and lossless. However, that doesn’t necessarily mean they’re 

high quality; as with any kind of audio encoding, the sampling and bit rate can be set 

to any value desired. For example, Ubuntu includes a default .wav encoding profile of 

low quality that can be used when encoding speech. Although WAV files tend to be 

supported on most computing platforms, the downside is file size. Uncompressed 

WAV files can be massive, even those with low-quality settings. If uncompressed 

audio is your aim, FLAC offers a far better alternative.

MP3: This is by far the most ubiquitous music file format, and practically everyone 

who owns a computer has at least a handful of MP3 tracks. This means software 

support for MP3 playback is strong, and of course, portable audio players are built 

around the MP3 standard. The only problem for you, as a Linux user, is the issue of 

surrounding patents, as explained at the beginning of this chapter. Using the MP3 

format goes against a lot of what the Linux and open source movement stands for. But 

in the end, the choice is yours. 

Adding MP3-Ripping Support to Sound Juicer

Support for Ogg and FLAC is built into Sound Juicer, but if you wish to encode CD tracks 

as MP3s, you’ll need to enter some configuration details into Sound Juicer. You’ll also 

need to manually install the gstreamer0.10-plugins-ugly-multiverse software package, 

which includes the necessary encoding codecs. 

Follow these steps to configure MP3 encoding support and set MP3 as the default 

encoding format:

1. Open the Synaptic Package Manager (System ➤ Administration ➤ Synaptic 

Package Manager) and then click the Search button. 

2. In the Search dialog box, enter gstreamer ugly multiverse. Then click the dialog 

box’s Search button.

3. In the list of results, look for something like gstreamer0.10-plugins-ugly-multiverse 

(ensure you don’t get it mixed up with the similar package that has –dbg at the end; 

note that the version number in the middle of the file might be different). Click the 

check box alongside it and click Mark for Installation. You’ll be told that additional 

files need to be installed. This is fine. Click Apply on the main toolbar. 

4. Once Synaptic has finished installation, close the program. 

5. Select Applications ➤ Sound & Video ➤ Audio CD Extractor to start Sound Juicer.
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6. Click Edit ➤ Preferences. In the Preferences dialog box, click the Output Format 

drop-down list and select CD Quality, MP3 (MP3 audio). 

7. Click the Close button. 

Sound Juicer is now set up to rip CDs to MP3 format by default.

Ripping Tracks

When you’re ready to rip some music, insert the audio CD, and then start Sound Juicer. If 

the CD isn’t read immediately, click Disc ➤ Re-read Disc. 

Click Edit ➤ Preferences. In the Format part of the dialog box, choose the type of audio 

files you want to create: Ogg Vorbis, FLAC, or MP3 (if you’ve followed the instructions in 

the previous section to install the gstreamer0.10-plugins-ugly-multiverse package). In 

addition, you can select where you would like the files to be saved by clicking the drop-down 

list under the Music Folder heading. Click the Close button after setting your preferences.

■Note  Audio tracks will be saved in a directory named after the artist and in a subdirectory named after the 

album title.

Back in the main Sound Juicer window, any track in the listing with a check in its box 

will be ripped. When you insert a CD, Sound Juicer assumes that all the tracks are to be 

ripped. If this isn’t the case, remove the checks from the tracks you don’t want to rip, as 

shown in Figure 18-5. By selecting a track and clicking the Play button, you’ll be able to 

audition it. This can be helpful if you’re deciding on exactly which tracks to rip. Finally, 

check that the Title and Artist information is correct.

To begin the ripping process, click the Extract button. It can take up to a minute or so 

to rip each track, so ripping an entire CD may take some time. However, it’s safe to leave 

Sound Juicer working in the background.

■Tip  You can also use Rhythmbox to rip tracks. Simply select the CD in the leftmost pane and click Copy to 

Library from the toolbar. To change the file format (Vorbis, MP3, and so on), click Edit ➤ Preferences, click 

the Music tab in the Preferences dialog box, and select a format from the Preferred Format drop-down list. By 

default, the files will saved in the Music folder in your home directory, but you can change the location by 

updating the Library Location setting on the Music tab of the Preferences dialog box.
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Figure 18-5. Audio tracks can be ripped from CDs using the Sound Juicer program.

MAKING MUSIC AND RECORDING AUDIO

Most PCs come with sound cards that are capable of making music. You can use many open-source 

programs, designed for both amateurs and professionals alike, to create music or record and edit audio. 

In terms of musical sequencers, MusE (www.muse-sequencer.org), Rosegarden  

(www.rosegardenmusic.com), and Jazz++ (jazzplusplus.sourceforge.net) are well worth 

investigating. Like all modern MIDI sequencers, these programs let you record audio tracks, effectively 

turning your PC into a recording studio.

It’s also possible to run virtual synthesizers on your PC, which effectively turn even the most basic sound 

card into a powerful musical instrument. Examples include Bristol (https://sourceforge.net/

projects/bristol) and FluidSynth (http://fluidsynth.resonance.org/trac).

If you’re interested in only audio recording and processing, Sweep (www.metadecks.org) and 

Audacity (http://audacity.sourceforge.net) are worth a look. In addition to audio recording and 

playback, both feature graphical waveform editing and powerful filters. 

Most of the packages mentioned here are available from the Ubuntu software repositories, and you 

can download them with the Synaptic Package Manager.

Creating Your Own CDs
You can create audio CDs using Brasero, which aims to be a complete CD-burning suite, 

like Nero under Microsoft Windows. 
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Start by inserting a blank CD. By default, Nautilus’s CD/DVD Creator will automatically 

run. Close that window, and then start Brasero by clicking Applications ➤ Sound & Video ➤ 

Brasero Disc Creator.

■Tip  If you want Brasero to open each time you insert a blank CD, right-click the CD icon on the desktop 

and select Open with Brasero Disc Burning. When you’re prompted to decide whether Brasero should be the 

default application for burning data discs, click Yes.

When Brasero’s main window appears, it will by start with a new Data project, by 

default. To create an audio CD, click the Audio Project button (or click Project ➤ New 

Project ➤ New Audio Project).

The program is very simple to use:

1. On the left side of the main window, browse to your store of files. These can be Ogg, 

FLAC, or MP3 files (if you installed the MP3 playback software, as described in the 

“Installing Codecs” section earlier in this chapter). Note that the Fluendo codec 

will also work for burning CDs from MP3 tracks.

2. Select the tracks you wish to go onto the CD. As with Windows, Shift-click to select 

many contiguous tracks at once, or Ctrl-click to choose multiple individual tracks. 

Drag-and-drop the selected tracks onto the right portion of the main window. 

3. You’ll see the track listing build up in the window where you dropped the selected 

tracks. In addition, a bar at the bottom of the program window will fill up, showing 

how much space is left on the CD. If desired, rearrange the track listing by clicking 

and dragging the tracks to new locations. 

4. When you’re satisfied with the track listing, click the Burn button to prepare your 

disc for burning. 

5. In the Disc Burning Setup dialog box, click the Burn button to start the write pro-

cedure. First, the tracks are converted to pure audio files, and then they’re actually 

burned to disc, as shown in Figure 18-6. This can take some time. When Brasero 

finishes with the burning, the CD will be ejected.

■Note  Depending on the quality of the blank CD, you might not be able to write audio CDs at full speed. If 

this is the case, Brasero will stop during the writing process with an error message. You’ll need to adjust the 

burn speed. To do so, in the Disc Burning Setup dialog box, click the Properties button and choose a more 

conservative speed from the Burning Speed drop-down list. 
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Figure 18-6. Brasero makes it easy to create CDs from digital audio files. 

Installing Skype
Skype is used by millions of people around the world to make Internet telephone calls via 

VoIP. This is a complicated way of saying that voice calls are transmitted across the Internet. 

Using Skype, it’s possible to call other Skype users for free, or to call various phone numbers 

around the world, usually for a small charge. 

Installing Skype is easy, and the Skype developers have even created a software repository 

from which it can be installed. This means that you’ll be informed via Update Manager 

whenever a new version of Skype becomes available. 

To add the Skype repository, click System ➤ Administration ➤ Software Sources. Click 

the Third-Party Software tab in the window that appears, and then click the Add button. 

In the APT Line text box, type the following:

deb http://download.skype.com/linux/repos/debian/ stable non-free

Note the spaces between debian/ and stable and between stable and non-free. Click 

the Add Source button. Click Close, and then click the Reload button in the dialog box that 

appears. 

To install Skype, open the Synaptic Package Manager (System ➤ Administration ➤ 

Synaptic Package Manager). Click Search, type skype into the search box, and click Search. 

In the list of results, put a check alongside the entry, and click Mark for Installation. You’ll 

see an error message about Skype not being authenticated and that an additional package 

needs to be installed, but this is acceptable, so click the Mark button on the dialog box. 

Then click Apply on the toolbar to install the software. 

Once the software has installed, click Applications ➤ Internet ➤ Skype to start it. Using 

Skype under Linux is almost exactly the same as using the same program under Windows 

or Macintosh (without the SMS or texting feature), as shown in Figure 18-7. You’ll find 

excellent documentation at www.skype.com.
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■Tip  To configure your audio input devices, such as a microphone, right-click the Speaker icon at the top-

right of the desktop and select Open Volume Control. Then click and drag the Microphone slider as necessary. 

You may need to unmute the input by removing the red cross next to the speaker icon below the microphone 

sliders.

Figure 18-7. It’s easy to install Skype under Ubuntu, and it works in almost exactly the same 

way as it does under Windows or Macintosh.

Summary
This chapter has covered the audio functions built into Ubuntu and shown how, by down-

loading a few extra system files, you can play back the majority of audio files in existence. 

We started by discussing the moral and legal dilemmas associated with multimedia play-

back on a computer. Then we moved on to look at how to install the necessary codec files 

on your computer, before discussing how you can listen to music files, CDs, and online 

radio stations.

We examined how you can convert CDs into music files, and then the inverse of this: 

how you can create CDs using audio files. Finally, we examined how you can install Skype 

on your computer.

In Chapter 19, we’ll look at playing back movies and online animations using Ubuntu.


